Arducopter is limiting the total power output of my hexacopter to 37 amps when it has the potential for 66amps when at full throttle.

I bench tested many different motor and prop combinations to see which would be the most efficient for my arducopter hex 550.

I decided to use 6 x 1000kv motors with 9x4.7 props which deliver 710g of thrust at 11amps each at max throttle.

Why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.  (see mission planner tuning chart)

I understand that the controller needs reserve power for controlling stablization but 37 amps is only 56% of total power potential that could be used.

I have calibrated my escs many times thinking that was the problem but its not.

When i use my kk2 controller on the same hexacopter i get 52 amp draw at max throttle held down on the bench.

Is there a setting that i need to change to allow the controller to use more potential power.

I want to put more equipment on this craft but it needs more power.

Thanks in advance for your help.

the Chart below shows thrust output for each motor/ prop combination.

I decided to use a 1000kv motor with a 9x 4.7 prop. next chart

This chart is just the 1000 kv motor with 9x4.7 prop  

max thrust was 710 grams at 11amps

I went into the tuning page for Misson planner and see that at full throttle i am only drawing 37 amps for 6 motors.  Hexacopter held down at full throttle on the bench while connected to MP.  the hex draws about 25 amps at hover with no extra equipment on board.

why is arducopter limiting my throttle current draw to 37 amps when the max should be 6motors x 11 amps each = 66 amps.

I understand that the controller needs reserve power for controlling stablization but that is only 56% of total power potential that could be used.

Is there a setting that i need to change to allow the controller to use more potential power.

Views: 16678

Attachments:

Reply to This

Replies to This Discussion

i flew the hex while tethered to my laptop by usb so i could log the current while flying, i attached that log file.  There must be a way to unleash more power from arducopter.  

I am surprised no one answered your question.

Seems no one knows why this change was made in 2.8 or maybe it's all hush hush.

I am guessing it is for headroom to maneuver.

ARM you multicopter and lift one arm up, observe more power beyond max power when level is delivered to some motors to try and level the frame.

What you correctly described only happens when the frame is level.

Thank u for ur response, that make a lot of sense, when I fly aggressively in acro mode it sounds like it got tons of power in a sharp angled maneuver like reversing forward speed aggressively.

I hope someone responds with a solution to my problem. I will have to use another controller if this cant be fixed, my hex just can't fly with all my camera and fpv gear on it.

Thanks again joe

This headroom value MUST be configurable, or the guys with larger ships are going to have issues (of course, no one has a craft as large as mine, but still...).

I just blithely updated my APM software when 2.8 came out, and never realized this factor alone may have accounted for my last disappointing field test (ground effect aerodynamics dictate that higher power is required to lift off).

Please fix this.

Im having the same issue and would like to know what the solution is

My F450 was transformed into a ankle-biter after an update. It did my head in trying to work out why the machine could barely take off when at full stick.

My solution was to go into Mission Planner / Config / .... and because I haven't got a machine connected I can't tell which exact page it was ..... but what you are looking for is the maximum throttle setting. 

Once the slider was moved from ~30% up to >90% then the ability to fly returned. 

This setting was towards the bottom of one of the Arducopter set up pages - apologies for not being able to recall the exact one.

I hope that this is the solution for you as well.

MJ

This setting is at the bottom of the standard params page.  Mine was set to 1000 which I am assuming is 100 percent.  Will test amp draw again but not sure this will change anything.

There is also a thrust curve enable/disable.  From the Wiki:

Thrust Curve Enable (MOT_TCRV_ENABLE) Controls whether a curve is used to linearize the thrust produced by the motors. Default = Enabled.

Dont know if this would change anything either.

Yep - as noted by Criterion the Max Throttle (Thr_Max) can be found towards the bottom of the Arducopter / Standard Params. I'm using current version of Mission Planner 1.2.32.

Hope this gets you up off the floor.

MJ

I realized looking through the Adv Param list that the APM assumes a PWM range of 1000-2000 for each channel.  (there are some special cases like flight modes I think).  At any rate, I modified my end points in my transmitter so that on the radio calibration screen I saw as close to 1000 low and 2000 high PWM value (for the throttle channel).  I then re-calibrated the radio to the APM, and re-calibrated my ESCs (auto cal).  I now see 56A at full power from my previous 32A.  This is still not theoretical full amp draw, but much better.  I also noted that in my hands I started to get a high speed oscillation.  I have been trying to dial in the PIDs using the auto tuning, but could never get it to start oscillating in the air.  I think it may be beneficial to tune the other channels (primarily 1-4) to have the optimal PWM limit but I have not tried this.  I will fly it first with the new throttle settings.

This is on a JR 9303 TX, APM 2.5, and DJI 30A opto controllers

Hi,
Please don't forget that when giving a multicopter full throttle, the motors should NOT all go up to full speed (as when their PWM input is connected directly to channel 3 of the rx).
If set up like that, there is no (upward) throttle reserve for stabilizing and controlling it..
Regards
Soren

Yes, but only getting 50% of full thrust?  To me that is unacceptable.  Especially when the aircraft is not lifting anywhere near the payload it should.  I would rather take the risk of losing some stability at the outer edges of the flight envelope (which I rarely reach).

Ok, tested my new settings as I described previously setting the PWM limits.  Flies fantastic now, lots of power and control. I had turned some of my P rates very high when it wasnt flying right, so I re-set them before flying again and am now re-tuning.  I suggest going back to default PIDs (or a setup that was flying previously) and also hand testing before letting it go.

I will try changing the PWM limits on the other channels too, but wont get to that for a few days.

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2017   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service